Subject: [yam] RFC 3282 status

From: Harald Alvestrand <[email-masked]>
Date: Wed, 19 Aug 2009 13:24:18 +0200

Just because I saw a discussion of this over on LTRU, I reviewed it with 
more care, and thought I should give a report here.

My opinion is:

- Document does not need any technical changes.
- If people want to open the document to fix nits and replace boilerplate:

  - References need to be split into normative and informative, and 
unused ones pruned
  - The language tag reviewer is now the language subtag reviewer
  - There is no explicit statement that Language-Tag is an ABNF construct
    imported from BCP 47
  - Reference to BCP 47 should be rewritten to say "currently RFC 4646", 
since it's    
    possible to construe the current text as referring to 3066 only
  - References can be updated to latest versions of referred-to specs.
  - There's always some English grammar that can be polished.

But I think that's all.

Resulting boilerplate, my opinion:

-------
The YAM WG has evaluated the following document for advancement from 
draft to full standard:
 http://tools.ietf.org/html/rfc3282
Date published: May 2002

Link to draft standard interop report:
 ... http://www.ietf.org/iesg/implementation/report-rfc1766.txt

Proposed Changes (the WG proposes making the following changes in a 
revision):
 ... None

Non-Changes (the WG discussed and chose not to make the following changes):
 ... Informative/Authorative references split

Downrefs (At full standard, the following references would be downrefs):
 ... 2045 (I), 2046 (I), 2047 (I), 2048 (I), 2049 (I), 2234 (N), 2616 
(N), 2822 (N)
  2234 (ABNF) is obsoleted by 5234, Standard. OK.
  2616 (HTTP/1.1), referenced for q semantics, is Draft Standard.
  2822 (Mail), referenced for CFWS syntax, is now 5322, Draft standard.

  We suggest that an exception be authorized for 2616 and 2822.

The YAM WG requests feedback from the IESG on this decision.  In 
particular:
1. Does the IESG believe the proposed changes are suitable during a move 
from draft to
  full standard?
2. Does the IESG believe any other proposed changes are necessary to 
satisfy IESG
  requirements to advance to full standard?
3. Does the IESG consider the downrefs acceptable for a full standard?
--------

                   Harald

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 19 Aug 2009 09:34:19 -0700

I mostly agree with Harald's analysis. The main problem is one of sorting out the references. It would also be useful to refer to the RFC about matching language tags (4647, which is part of BCP 47). 

No technical changes are required. Note that 4646 is about to be replaced by 5646 (in AUTH48).

I endorse Harald's proposed boilerplate.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Harald Alvestrand
> Sent: Wednesday, August 19, 2009 4:24 AM
> To: [email-masked]
> Subject: [yam] RFC 3282 status
> 
> _______________________________________________
> yam mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yam