Subject: [yang-doctors] binary encoded YANG data: side meeting in Chicago?

From: Andy Bierman <[email-masked]>
Date: Sun, 19 Feb 2017 12:05:58 -0800

Hi,

The CORE WG is working on some standards for an IoT version of RESTCONF.
The CBOR encoding is relevant to RESTCONF for some applications like YANG
push.

I am trying to organize a side meeting about YANG to CBOR and
SID (numeric schema node identifiers). The goal of the meeting is
understand how it works (and doesn't work).  Hopefully there will be a
1 hour slot open for this meeting, and a room available.
The first step is determining if any YANG doctors care about what
the CORE WG is doing with YANG.

Another topic: YANG to GPB? Better approach? Where is it documented?
Does an algorithm exist that works for YANG augment?

CORE WG drafts:

YANG to CBOR
https://datatracker.ietf.org/doc/draft-ietf-core-yang-cbor/

SID
https://datatracker.ietf.org/doc/draft-ietf-core-sid/

CoMI
https://datatracker.ietf.org/doc/draft-ietf-core-comi/

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 20 Feb 2017 08:06:21 +0100

Hi Andy,

I would be interested in attending that meeting.

Lada

> On 19 Feb 2017, at 21:05, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> The CBOR encoding is relevant to RESTCONF for some applications like YANG push.
> 
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Mehmet Ersue <[email-masked]>
Date: Mon, 20 Feb 2017 12:51:44 +0100

me2

Cheers,
Mehmet
(Sent from my iPad)

> Am 20.02.2017 um 08:06 schrieb Ladislav Lhotka <[email-masked]>:
> 
> Hi Andy,
>

---

From: Radek Krejčí <[email-masked]>
Date: Mon, 20 Feb 2017 12:56:04 +0100

+1

Radek

-- 
Radek Krejci
mobile  : +420 732 212 714
office  : +420 234 680 256
e-mail  : [email-masked]
LinkedIn: http://www.linkedin.com/in/radekkrejci

CESNET, Association of Legal Entities
Zikova 4
160 00 Praha 6
Czech Republic

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 20 Feb 2017 06:49:07 -0800

Ditto.

> On Feb 20, 2017, at 3:56 AM, Radek Krejčí <[email-masked]> wrote:
> 
> +1
> 
> Radek
> 
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 21 Feb 2017 15:29:51 +0000

Likewise

Kent