Subject: Re: [yang-doctors] How to inform that a device doesn't support RPC statement

From: Orly Kariv <[email-masked]>
Date: Tue, 15 Aug 2017 14:43:22 +0000

Hello,
My name is Orly Kariv and I'm system architect in ECI.
If I understand correctly deviation is done on nodes.
RPC and Notifications are not treated as node. Correct ?

Ietf-isis.yang introduces two RPC statements.

rpc clear-adjacency
rcp clear-databse

Our device doesn't support one of the RPC statements.
How to inform netconf client that our device doesn't support this RPC ?
I prefer not to respond to the rpc call with rpc-reply-error.

Please your advice
Regards,
Orly Kariv

Office: +972-39287714
Cell:      +972-549287714
Email: [email-masked]<mailto:[email-masked]>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Andy Bierman <[email-masked]>
Date: Tue, 15 Aug 2017 17:04:59 -0700

Hi,

Look at the YANG deviation-stmt.
Your server can advertise a deviation for the RFC to indicate it is not
supported.
You also need to return rpc-error 'operation-not-supported' if a client
tries it.

Andy

On Tue, Aug 15, 2017 at 7:43 AM, Orly Kariv <[email-masked]> wrote:

> Hello,
>
> My name is Orly Kariv and I’m system architect in ECI.
>
> Our device doesn’t support one of the RPC statements.
>
> How to inform netconf client that our device doesn’t support this RPC ?
>
> Email: [email-masked]
>
>
>
>
>
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 15 Aug 2017 17:47:58 -0700

Thanks Andy. I have gone ahead and added this to the YANG doctors FAQ here:

https://trac.ietf.org/trac/ops/wiki/YANGDoctorsFAQ#HowdoesaNETCONFserverinformaclientthattheserverdoesnotsupportRPCstatement <https://trac.ietf.org/trac/ops/wiki/YANGDoctorsFAQ#HowdoesaNETCONFserverinformaclientthattheserverdoesnotsupportRPCstatement>

> On Aug 15, 2017, at 5:04 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> Your server can advertise a deviation for the RFC to indicate it is not supported.
> You also need to return rpc-error 'operation-not-supported' if a client tries it.
> 
> 
> Andy
> 
> 
> On Tue, Aug 15, 2017 at 7:43 AM, Orly Kariv <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> Email: [email-masked] <mailto:[email-masked]>
>  
> 
>  
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/yang-doctors <https://www.ietf.org/mailman/listinfo/yang-doctors>
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: Orly Kariv <[email-masked]>
Date: Wed, 16 Aug 2017 07:07:20 +0000

Hi Andy,
Thanks for the quick response.
Actually I tried to follow RFC6020 and RFC7950 with no success.
I tried using the deviation statement for RPC and Notifications and failed on compilation via confdc and pyang.

The relevant RFC I want to deviate is: [email-masked]<mailto:[email-masked]>:

Enclosed deviation statements for RPC and Notification (marked):
/* Event counters not supported */
                deviation "/rt:routing/"
                               +"rt:control-plane-protocols/rt:control-plane-protocol"
                                +"/isis:isis/isis:interfaces/isis:interface/isis:event-counters/isis:init-fails" {
                                deviate not-supported;
                }

  /* RPC  Deviation */
                deviation "/isis:rpc/isis:clear-adjacency" {
                deviate not-supported;
  }

  /* notification deviation */

                deviation "/isis:notification/isis:corrupted-lsp-detected" {
                deviate not-supported;
                }

                deviation "/isis:notification/isis:database-overload" {
                deviate not-supported;
                }

Running pyang
pyang --strict eci-isis-dev\@2017-07-19.yang -f tree -o result.txt
[email-masked]:156: error: node ietf-isis::rpc is not found
[email-masked]:165: error: node ietf-isis::notification is not found
[email-masked]:169: error: node ietf-isis::notification is not found

Running confdc

/u/lni/Confd_6.4_x86_64/bin/confdc --fail-on-warnings -c -o [email-masked] [email-masked]
[email-masked]:156: error: node 'rpc' not found
[email-masked]:165: error: node 'notification' not found
[email-masked]:169: error: node 'notification' not found

Regards
Orly Kariv

From: Andy Bierman [mailto:[email-masked]]
Sent: Wednesday, August 16, 2017 3:05 AM
To: Orly Kariv <[email-masked]>
Cc: [email-masked]
Subject: Re: [yang-doctors] How to inform that a device doesn't support RPC statement

Hi,

Andy

On Tue, Aug 15, 2017 at 7:43 AM, Orly Kariv <[email-masked]<mailto:[email-masked]>> wrote:
Hello,
My name is Orly Kariv and I’m system architect in ECI.
If I understand correctly deviation is done on nodes.
RPC and Notifications are not treated as node. Correct ?

rpc clear-adjacency
rcp clear-databse

Please your advice
Regards,
Orly Kariv

Office: +972-39287714
Cell:      +972-549287714

_______________________________________________
yang-doctors mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 16 Aug 2017 09:12:55 +0200 (CEST)

Orly Kariv <[email-masked]> wrote:
> I tried using the deviation statement for RPC and Notifications and
> failed on compilation via confdc and pyang.
> 
> The relevant RFC I want to deviate is:
> [email-masked]:
> 

The error message is pretty clear - there is no node called "rpc" in
the "ietf-isis" module.  You should do:

  deviation "/isis:clear-adjacency" {
    deviate not-supported;
  }

/martin

---

From: Orly Kariv <[email-masked]>
Date: Wed, 16 Aug 2017 07:19:10 +0000

Hi Martin,

Thank you very much.
Regards 
Orly

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: Wednesday, August 16, 2017 10:13 AM
To: Orly Kariv <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [yang-doctors] How to inform that a device doesn't support RPC statement

> [email-masked]:156: error: node ietf-isis::rpc is not 

The error message is pretty clear - there is no node called "rpc" in the "ietf-isis" module.  You should do:

/martin