Subject: Re: [yang-doctors] Fwd: [OpenROADM/OpenROADM_MSA_Private] modify the routing and ip entries to remove IETF from the name (#427)

From: Christian Hopps <[email-masked]>
Date: Fri, 20 Apr 2018 07:09:57 -0400

What is this work? Are they copying entire IETF models and changing things to suit them? If so do we know why they are doing that? This seems bad.

Thanks,
Chris.

Benoit Claise <[email-masked]> writes:

> Dear all, Ignas,
>
> Should be offended by this practice below?
>
> Regards, Benoit
>
>
> -------- Forwarded Message --------
> Subject: 	[OpenROADM/OpenROADM_MSA_Private] modify the routing and ip
> entries to remove IETF from the name (#427)
> Date: 	Tue, 27 Mar 2018 08:49:05 -0700
> From: 	fnc-se <[email-masked]>
> Reply-To: 	OpenROADM/OpenROADM_MSA_Private
> <reply+0069c7bcf54afd570898[email-masked]>
>
> To: 	OpenROADM/OpenROADM_MSA_Private
> <[email-masked]>
> CC: 	Subscribed <[email-masked]>
>
>
>
> Modify the name entries for routing and ip to remove 'ietf' from the
> namespace.
> This was mentioned in the morning teleconference on 3/27 from Fred.
>
> ------------------------------------------------------------------------
>
>
>         You can view, comment on, or merge this pull request online at:
>
> https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427
>
>
>         Commit Summary
>
>   * modify the routing and ip entries to remove IETF from the name
>
>
>         File Changes
>
>   * *R* Device/org-openroadm-ip.yang
>     <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427/files#diff-0>
>     (10)
>   * *R* Device/org-openroadm-ipv4-unicast-routing.yang
>     <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427/files#diff-1>
>     (16)
>   * *R* Device/org-openroadm-ipv6-unicast-routing.yang
>     <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427/files#diff-2>
>     (16)
>   * *R* Device/org-openroadm-routing.yang
>     <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427/files#diff-3>
>     (16)
>   * *M* Device/tree-view-device.txt
>     <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427/files#diff-4>
>     (166)
>
>
>         Patch Links:
>
>   * https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427.patch
>   * https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427.diff
>
> —
> You are receiving this because you are subscribed to this thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/OpenROADM/OpenROADM_MSA_Private/pull/427>, or mute
> the thread
> <https://github.com/notifications/unsubscribe-auth/AGnHvPH_OFK1M-zY-pDerceehwmwz5-Eks5til9xgaJpZM4S9LYD>.
>
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Jan Lindblad <[email-masked]>
Date: Fri, 20 Apr 2018 13:24:14 +0200

Team,

If much of the original text remains, this sounds like copyright infringement to me.

/jan

> On 27 Mar 2018, at 23:51, Ebben Aries <[email-masked]> wrote:
> 
> On Mar 27 23:34 PM, Benoit Claise wrote:
>> Dear all, Ignas,
>> 
> OpenROADM is doing many bad things atm imo...
> 
> These sit in a private repo I don't have access to but imagine the
> context is merely copying, modifying and renaming of certain modules.
> I've seen that they have done this in other modules before as well where
> it involved cut/paste of nodes, notifications, etc.. where they were
> taking IETF definitions and slightly modifying within their modules
> (e.g. 'change-notification' is a replica of 'netconf-config-change')
> 
> OpenConfig types modules took a similar approach some time back as
> well..
> 
>> Regards, Benoit
>> 
>> 
>> Reply-To: 	OpenROADM/OpenROADM_MSA_Private <reply+0069c7bcf54afd570898[email-masked]>
>> 
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=qIbV8QPS6OlTWTGYyykMELavplz0sCL6PIn0_N0XjU8&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=qIbV8QPS6OlTWTGYyykMELavplz0sCL6PIn0_N0XjU8&e=>
>> 
>> 
>>       Commit Summary
>> 
>>   <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D0&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=jiBFqB9yqw47swg80H88NCywtfUSWSqWXQPX5JXw7aA&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D0&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=jiBFqB9yqw47swg80H88NCywtfUSWSqWXQPX5JXw7aA&e=>>
>>   (10)
>>   <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D1&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=FlKvJjj6vvm9XU44D0OgDWH4M9gi81jU4wY5eErGg_s&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D1&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=FlKvJjj6vvm9XU44D0OgDWH4M9gi81jU4wY5eErGg_s&e=>>
>>   (16)
>>   <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D2&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=rjbJviP10uIiIniyGWu4vNLfvo5dWseWEW6ll5fqrBQ&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D2&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=rjbJviP10uIiIniyGWu4vNLfvo5dWseWEW6ll5fqrBQ&e=>>
>>   (16)
>>   <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D3&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=52r2b6i1gJxkldw6yc_RBRy7VqVH8abJ2LYePuwiKoU&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D3&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=52r2b6i1gJxkldw6yc_RBRy7VqVH8abJ2LYePuwiKoU&e=>>
>>   (16)
>>   <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D4&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=C2CCRI1lunvyA1R3QU3UQf2S0IBdC6RotBNaiknHSkk&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427_files-23diff-2D4&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=C2CCRI1lunvyA1R3QU3UQf2S0IBdC6RotBNaiknHSkk&e=>>
>>   (166)
>> 
>> 
>>       Patch Links:
>> 
>> * https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427.patch&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=xlMAHzXxwVzLZ26jSt8r4ej1jxYk7S12kOXpElfnw4s&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427.patch&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=xlMAHzXxwVzLZ26jSt8r4ej1jxYk7S12kOXpElfnw4s&e=>
>> * https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427.diff&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=eJR56vnm3gNN8ug7OqHzDM_6E62pu6Ck5R8bdAWdCjo&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427.diff&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=eJR56vnm3gNN8ug7OqHzDM_6E62pu6Ck5R8bdAWdCjo&e=>
>> 
>> —
>> Reply to this email directly, view it on GitHub <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=qIbV8QPS6OlTWTGYyykMELavplz0sCL6PIn0_N0XjU8&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_OpenROADM_OpenROADM-5FMSA-5FPrivate_pull_427&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=qIbV8QPS6OlTWTGYyykMELavplz0sCL6PIn0_N0XjU8&e=>>,
>> or mute the thread <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_notifications_unsubscribe-2Dauth_AGnHvPH-5FOFK1M-2DzY-2DpDerceehwmwz5-2DEks5til9xgaJpZM4S9LYD&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=IRa0sjxgyCvF6XehizQGHFVFVevDW86zLn5OzWfqe-s&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_notifications_unsubscribe-2Dauth_AGnHvPH-5FOFK1M-2DzY-2DpDerceehwmwz5-2DEks5til9xgaJpZM4S9LYD&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=IRa0sjxgyCvF6XehizQGHFVFVevDW86zLn5OzWfqe-s&e=>>.
>> 
> 
>> [email-masked] <mailto:[email-masked]>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_yang-2Ddoctors&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=u-XqpjEA653algsShEwzdeJs5_KvFlNxEiCy-BLScNY&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_yang-2Ddoctors&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=GIehbDpQlo31lSi6WbnEkA&m=hw3ok0A_tEAtDofWf3C0T3_WeEAy9iRMWyxFngQyMsE&s=u-XqpjEA653algsShEwzdeJs5_KvFlNxEiCy-BLScNY&e=>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/yang-doctors <https://www.ietf.org/mailman/listinfo/yang-doctors>

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 20 Apr 2018 13:50:20 +0200 (CEST)

> If much of the original text remains, this sounds like copyright

I don't think so; the original modules are under BSD license, and they
keep the IETF copyright and license in ther modules, from what I can
see.

/martin