Subject: [yang-doctors] Question on upper/lower-case identities

From: "Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept)" <[email-masked]>
Date: Wed, 16 Jan 2019 02:14:26 +0000

Dear YANG doctors,

This is Haomian, the editor of a few IETF YANG documents with a team implementing IETF YANG models, I am writing to ask the following question.

In the section 6 of draft-ietf-ccamp-otn-tunnel-model-05, the module ietf-otn-types contains some identities with upper-case, such as ‘ODU0’. We noticed that in published modules, these are usually in lower-case format. On the other hand, I checked the module ietf-otn-types on yang validator and there is no warning/error feedback, also there is no restrictions on lower/upper-case in guideline documents such as RFC8407, there is also modules from other SDOs with upper-case identities.

Currently we are using some upper-case identities, therefore I am checking with you whether there will be potential requests to change to lower-case for RFC publication. The changes in implementation will cause the compatibility problem, so I wish to make the right decision at this moment, thank you.

Best wishes,
Haomian

________________________________
华为技术有限公司 Huawei Technologies Co., Ltd.
[Company_logo]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 16 Jan 2019 07:43:10 +0100

The IETF preferences are actually described in RFC 8407, see section
4.3.1 on page 18:

4.3.1.  Identifier Naming Conventions

   Identifiers SHOULD follow a consistent naming pattern throughout the
   module.  Only lowercase letters, numbers, and dashes SHOULD be used
   in identifier names.  Uppercase characters, the period character, and
   the underscore character MAY be used if the identifier represents a
   well-known value that uses these characters.  YANG does not permit
   any other characters in YANG identifiers.

I read this as "we prefer lowercase but there can be exceptions in
situations where the are existing well-known writings using uppercase
characters".

/js

> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept)" <[email-masked]>
Date: Wed, 16 Jan 2019 07:19:07 +0000

Hi, Juergen, 

Thank you for the reply, I missed this section... it helps!

Best wishes,
Haomian

-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]] 
发送时间: 2019年1月16日 14:43
收件人: Zhenghaomian (Zhenghaomian, Optical &Microwave Technology Research Dept) <[email-masked]>
抄送: [email-masked]
主题: Re: [yang-doctors] Question on upper/lower-case identities

I read this as "we prefer lowercase but there can be exceptions in situations where the are existing well-known writings using uppercase characters".

/js